SOLVED Issues with Doctype permission

Hi, I run the latest version of ERPnext and I have some issues.

On item I don’t have the Item group field. If I try to create a new Item the system ask me to chose the Item group but I don’t have this option.

I look on the docktype to see if I can enable it but I can’t edit any doctype. I’m logged as Administrator

thanks for your help


1 Like

Check that item group did not become hidden by using Customize Form->Item and looking at the Item Group field.

On that section the mandatory, in list view, in filter are checked

What is item group set to be after? I have mine after item name and it is still there.

Can you share a screenshot of your item page, and the item_group in customize form? I can’t replicate the issue.

Don’t check in Doctype record, you should check Setup → Customize Form → Item.

The third screenshoot are from the Setup Customize form

Someone knows how to resolve this issues?

I make some test. I restore my snap shoot taken 2 weeks ago. I restore the setting the files and all work greate. Soon I restore my database from my daily backup the problem come again.

Where in the database I can change the option to hide or show this option

Hi all I finaly found the bug.

On my DB in default value I have found this entry
11:23:37.950158’,‘2016-02-18 11:23:37.950158’,‘’,‘’,0,‘__default’,‘system_defaults’,‘__default’,0,‘0’,‘fs_item_group_in_details’),(‘d0c8194a50’,‘2016-02-10 15:09:24.617914’,'2016-02-10

I take all default value section from a working DB backup and past it on my latest DB backup and do a restoration/migration and I’m all set.

This fix also the problem I got to change the permission on Doctype

1 Like