[Solved] New v12 install cannot get to login screen

Ok, so today I finally got a successful install using the easy install method described here:

However, when I attempt to get to the login screen in order to run the setup wizard, I get the following screen:

I know that I have seen this before, but I cannot seem to get past it now.

I have already tried the following things:

bench update
bench setup nginx
sudo service nginx restart

After this I still get the same landing page and the “Login” link does not in fact take you to a login screen so I am unable to get into the freshly installed system to start the setup wizard (you know, the script that runs with the first login if the Administrator).

Has anyone else been here and got past this?


bench update fixed this for me, can you try a bench update and post the log if you come across any errors.

I had done bench update previously but did not notice any errors because I walked away from the terminal as it was working. I just ran it again and traced back to see the errors this time as follows:

Updating node packages...
Please install yarn using below command and try again.
`npm install -g yarn`
Patching sites...
Migrating site1.local
Updating DocTypes for frappe        : [========================================]
Updating DocTypes for erpnext       : [========================================]
Updating customizations for Address
Generating Website Theme Files...
Compiling Python Files...
INFO:bench.utils:bench build
Please install yarn using below command and try again.
npm install -g yarn

> frappe@ production /home/erp_jmi/frappe-bench/apps/frappe
> FRAPPE_ENV=production node rollup/build.js

    throw err;

Error: Cannot find module 'chalk'
    at Function.Module._resolveFilename (module.js:548:15)
    at Function.Module._load (module.js:475:25)
    at Module.require (module.js:597:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/home/erp_jmi/frappe-bench/apps/frappe/rollup/build.js:3:15)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
npm ERR! errno 1
npm ERR! frappe@ production: `FRAPPE_ENV=production node rollup/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the frappe@ production script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm WARN Local package.json exists, but node_modules missing, did you mean to install?

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/erp_jmi/.npm/_logs/2019-12-19T23_29_34_966Z-debug.log
INFO:bench.utils:sudo supervisorctl restart frappe-bench-workers: frappe-bench-web:
frappe-bench-workers:frappe-bench-frappe-schedule: stopped
frappe-bench-workers:frappe-bench-frappe-long-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-default-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-short-worker-0: stopped
frappe-bench-web:frappe-bench-frappe-web: stopped
frappe-bench-workers:frappe-bench-frappe-schedule: started
frappe-bench-workers:frappe-bench-frappe-default-worker-0: started
frappe-bench-workers:frappe-bench-frappe-long-worker-0: started
frappe-bench-workers:frappe-bench-frappe-short-worker-0: started
frappe-bench-web:frappe-bench-frappe-web: started
frappe-bench-web:frappe-bench-node-socketio: ERROR (spawn error)

I see npm errors and a socketio error at the end.

Not sure why the npm errors though.


i think i might have tried that as mentioned in the log
sudo npm install -g yarn
that is in the log, and now i vaguely remember. That is why i was asking for the log.
you should give it a try, i think it should work after you do that.

edit: i just checked and i do have yarn installed, which confirms that i used that command.

Yup… actually had to use:

sudo npm install -g yarn

And now bench update is running again and taking much longer this time to complete, so I think yarn was the stumbling block. If that fixes it, then I will update the install error post with the additional steps to get the system to run.


ill wait for your confirmation before i hit the sack.
The bench update took really long for me as well, actually mine stopped once because of swapfile issues but it did work the second time.

Yup that did it!

Thanks again. I will update the other thread with the additional instructions so someone else may benefit from our troubles.

Good Night! :grin:


1 Like

Great job documenting this, when i was going through this on my own the “sudo npm install -g yarn” is the only thing i failed to retain. Simply because i was ecstatic about getting a running install.

1 Like

I facing this issue , upgrade ram from 1g to 2G solve the problem .
also, I updated the ram swap file

Hi, I faced the similar situation and it was fixed.

First of all increased RAM memory to 2GB and execute the following commands:

sudo npm install -g yarn
bench build