[solved]Problem to update v8

When i updating to V8 I think in last level i got this error , some one know what’s problem ?

Wrote ./assets/js/d3.min.js - 343k
Wrote ./assets/css/form.min.css - 4k

Your bench was upgraded to version 8
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==3.0.0’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/cli.py”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/commands/update.py”, line 62, in update
_update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force, reset=reset)
File “/home/frappe/bench-repo/bench/commands/update.py”, line 101, in _update
post_upgrade(version_upgrade[1], version_upgrade[2], bench_path=bench_path)
File “/home/frappe/bench-repo/bench/utils.py”, line 546, in post_upgrade
File “/home/frappe/bench-repo/bench/config/redis.py”, line 32, in generate_config
“maxmemory”: config.get(‘cache_maxmemory’, get_max_redis_memory()),
File “/home/frappe/bench-repo/bench/config/redis.py”, line 65, in get_max_redis_memory
import psutil
ImportError: No module named psutil

hi meisam, try this:
pip install psutil

and re update.

solved , thanks :wink:

1 Like