[solved] TASK [init bench] failed in "install.py --production" on Ubuntu 16.04.3 LTS 32-bit fresh install

Hello, I have searched on google and tried suggested solutions but I couldn’t get it to work. Tried installing multiple times on fresh Ubuntu installs but get the same error.

For info:

Machine: VirtualBox VM
Guest: Ubuntu 16.04.3 LTS 32-bit
RAM: 2gb
Python version: 2.7.12

I have tried installing with python install.py --develop --user erpnext --verbose as root

Traceback length exceeds limit of allowed post length so I pasted it on pastebin. Link below


Kindly suggest a solution?

The issue cannot be fixed from Frappe/ERPNext. Seems like a temporary issue with the installation of the node module chromedriver.

Seperately in a new directory try this,

npm install chromedriver 

You should see the error pop up. If not, on a fresh instance/VM, try installing again. You should succeed.

Thanks @codingCoffee Indeed the issue is with chromedriver. I was trying to install on 32-bit ubuntu but as of chromedriver v2.34 , 32-bit linux systems are no more supported according to Install fails for Linux on 32 bits and version 2.34 · Issue #136 · giggio/node-chromedriver · GitHub

I tried to install on Ubuntu 16.04.3 64-bit guest and it installed without any error. I think the README.md file of frappe bench should explicitly mention compatibility to only 64-bit systems.

1 Like