Solved: Timesheet won't submit: "Task's Actual Start Date cannot be after Project's End Date." - I didn't set an end date

Update: I resolved this after writing the post. I feel a little foolish now because I thought I had already tried this, but I have confirmed that the reason timesheets won’t submit for this error is if expected end date isn’t in the future. I’m posting this so anyone searching in the future might find this useful.

Once I updated this to a date in the future, the submit error went away and I can add time again.

Original Post:
“Task’s Actual Start Date cannot be after Project’s End Date.”

Here is the time I’m trying to apply to the project

Error on submit:

It’s been a while since I’ve worked on this project, taking a look at the end date:

and from documentation on Project ( It looks like the end date is set by the previous timesheets somehow:

It seems like my projects end date has already been decided based on the timesheets, and now I cannot submit another time sheet based on this end date. I got caught in some loop I didn’t create.

I don’t know how to change this project end date, I’ve tried through project doc type customization, and so I can’t submit any time now.

Does anyone know a way to override this or set the end date another way?