[solved] V12 to v14 upgrade

Howdy everyone.
I’ve been doing some other things so haven’t been on the forums much I a while. I want to upgrade my install which has been running quit happily on v12 for a loooong time. I have trolled for posts on how to do this but there’s a disturbing lack thereof.
The most common opinion seems to be “install v14 fresh and the migrate” - so I tried … install v14 (all fine - even used ubuntu 22 to match with the majority of the posts), and then data import of the v12 DB into v14 (also appears to go fine), but…
when I try
bench update -- patch
Right after the Building search index for site1.local
I get errors like this…

pymysql.err.OperationalError: (1054, "Unknown column 'is_virtual' in 'field list'")
pymysql.err.OperationalError: (1054, "Unknown column 'website_search_field' in 'field list'")

I thought that the primary purpose of migrate/patch was to correct DB schema mismatches?
Admittedly I have been out of the loop a while but has anyone actually succeeded in a v12->v14?
Am I better off doing a v12 → v13 upgrade…and then a v13 → v14 upgrade?


hello, yes it is better to go one step wen upgrading major versions


Highly recommend V12 > 13> 14

1 Like

Thanks guys…I have done a v13 install…restored v12 DB etc into v13, and migrated…will test shortly and revert on progress

1 Like

@trentmu welcome back boet :smiley:

1 Like

Thank you! Great to see a lot of new features and faces (but still some of the oldies)!

Thanks to everyone who commented/contributed… following the 12…13…(OS upgrade for python 3.10)+14 route worked.

1 Like

Hi Trent, could you guide the complete procedure for migration to v14 from v13? Thanks.

My steps were…

  • backup the database, and then delete it from mariadb.
  • move/rename the /home/frappe/frappe-bench/* subdir to another safe location (in my case I just renamed it to /home/frappe/ZZZfrappe-benchZZZ/)
  • do a fresh install of v14
  • do a forced restore of the db from the backup you took above
  • patch/migrate (I prefer to use the bench update --reset method, although there are other alternatives that also work)
1 Like

Everything worked well, except pdf generaterion of any document, what could be the issue? For v14, we need to install or congure anythinr else for this.

  • You need to check that the version you have of wkhtmltopdf is 0.12.6 or higher WITH qt patch.
    • Use wkhtmltopdf --version to check
  • Try adding the ERPNext domain name(s) into your /etc/hosts file
  • Try adding “host_name”: “https://YOUR.domain.com” in site_config.json,
1 Like

Could you elaborate more last two points as I’m using IP to access?

with IP address, there’s no point in adding the /etc/hosts entry
the 2nd part…add/edit your site_config.json

"host_name": ""

(you must use YOUR host machine’s IP address - the is just an example)

can you please define steps you took while performing this. will be very helpful