[SOLVED] [V7] Installation fails on DigitalOcean droplet

Hello Sirs;

Please I need help, I have tried this numerous times; destroyed and rebuilt the droplet and followed the instructions, created a sudo user that is not root in each instance; yet the installation fails; sometimes with some SNI error other times with this:

fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“mysqladmin”, “-u”, “root”, “password”, “12345”], “delta”: “0:00:00.007498”, “end”: “2016-08-07 22:53:04.854893”, “failed”: true, “rc”: 1, “start”: “2016-08-07 22:53:04.847395”, “stderr”: “\u0007mysqladmin: connect to server at ‘localhost’ failed\nerror: ‘Access denied for user ‘root’@‘localhost’ (using password: NO)’”, “stdout”: “”, “stdout_lines”: [], “warnings”: []}
to retry, use: --limit @production/install.retry

Can someone help with some direction? This installer is new and the script seems better but it’s failing for me. One thing comes to mind; the error from the script says using password: NO, that seems like a problem, am I correct?

@noetico Welcome to community! Thanks for reaching out to us.
Please Start with fresh instance of Ubuntu 14.04.X LTS and once logged in, download and run install.py as root with following:

# wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
# sudo python install.py --production

Thanks for the quick response, I will give this a shot; although I have done this severally, I hope you will still be available for any updates. Let me give it a shot

Make sure you are doing this on droplet of minimum 1GB RAM, otherwise it will fail due to low memory in come cases.

ok, let me upgrade, thanks I will drop a feedback now. My concern is the installer asks for mysql password to be created; but if you look at the error I pasted; generated from the script; root@localhost seems to be accessing without the password because it says using password: no

so in this case, I need to create a password you see.

@noetico Expected Behaviour! Installer is simply prompting you to enter your preferred password for MySQL root account.
Then it will also ask you to enter password for first default site1.local Administrator account.
Keep it safe, you will need it later, in case while adding new sites and apps to ERPNext/Frappe.

Keep this Handy:

Once setup is completed without errors.

  • You may access default site created by installer by entering your VPS Public IP address in your browser.
  • You may also able to add new sites using bench tool from CLI via SSH

Thanks, I’m on it now.

Hey Thanks! the base 512mb setup by my friend was the issue; it just worked flawlessly on upgrading to a 1 gb ram size, thanks a lo! many many thanks.

Glad to know, Happy Testing and Feel free to share your feedback and issues with us! :slight_smile: