Some installation errors/workarounds

Hi everyone,

I have CentOS 6 installed on my VPS container. I installed ERPNext using the installer. 

One issue I had to face is, my distribution is identified as "centos linux" instead of just "centos" and I couldn't go through with installation unless I manually edit the file and add "centos linux" in the redhat list. This might be an issue for others as well, so it can be updated in the source file itself.

Secondly, pytz didn't install and I had to install it separately using "yum install pytz" and run the installer again.

Lastly, after installing successfully and going to localhost:8080, was getting the following error 

<type 'exceptions.IOError'>: [Errno 13] Permission denied: '/usr/lib/python2.6/site-packages/httplib2-0.8-py2.6.egg-info/top_level.txt' 
      args = (13, 'Permission denied') 
      errno = 13 
      filename = '/usr/lib/python2.6/site-packages/httplib2-0.8-py2.6.egg-info/top_level.txt' 
      message = '' 
      strerror = 'Permission denied

Fixed it by changing file permissions from to -rw-r----- to -rw-r--r-- i.e. added Read permission to Others.

Same error also showed for google_api_python_client-1.1-py2.6.egg-info/  package and fixed the same way. Is this safe, for production server also? 




If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at or and send only the URL via email
  3. For sending images, use or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.


    End of Note

    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to

    For more options, visit