Some Issue in ERPNext V.10.1.14

  1. Customize form: when clicking the arrow to extend the field descriptions showing error.

  2. When clicking the save button status is not changing showing status as Not Saved and also submit button is not showing up. Only after refreshing the page submit button is showing up.

  3. Deadlock error is thrown on submit and cancel of documents.

1 Like

I came here to report the first and the second problem. :vulcan_salute:

To add to that my issue with “2.” is critical
I am unable to submit Sales invoice at all. below are the repro steps:

  • make an entry of Sales invoice and save it.
  • the submit button appears, Do not click on the submit now.
  • hit the refresh button on browser.
  • now sales invoice will appear as not saved and on pressing save you will not get the submit button ever after this

is there someone here who faces the same issue?

Also this is very critical for us since we are using API to populate the Invoice and then making additional changes and saving it from the UI. This Bug blocks our workflow completely since we cannot submit any invoices at all.

Hope this issue is fixed soon… we were planning to run ERPNext from 1st April and am afraid this issue will prevent us from doing so… hope its a simple fix :slight_smile: … i am new to ERPNext, and do not have the expertise to solve this issue. hope someone here can help me out…
Also there are no errors in the browser console…

run bench update to pull latest fixes

1 Like

awesome thanks… “2.” was indeed fixed in V.10.1.15…

After run bench update nothing changed for me. this is very serious type of issue, I have to change the naming series for the coming accounting year but form customization is not working.

Hey @Prashanta_Mahato ,
“1.” seemed to be solved for me. my guess is that it was solved for me after bench restart- though i am not certain…
also, try other stuff like ‘clearing browser cache’, trying from ‘different browser’ or login in from incognito…

BTW, if updating the naming series is your only blocking issue, you can do the same by visiting
Setup > Data > Naming Series page.

Hope this helps :slight_smile: