Sorry! We will be back soon. - After Installation of openSSH

After difficulty getting ERPNext installed on CentOS7, I am trying on UBUNTU. On UBUNTU I had no problems. Site was up and running perfectly after using install script. I then installed and setup OpenSSH. After that I get the:

We will be back soon.
Don’t panic. It’s not you, it’s us.
Most likely, our engineers are updating the code, and it should take a minute for the new code to load into memory.
Try refreshing after a minute or two.

Not sure how to enable error reporting to find out details.
I could set up my virtual machine and try again, but I’d rather learn how to tackle these kind of problems.

Anyone have any input?

I don’t really get how OpenSSH broke this. Can you run sudo supervisorctl status and give me the output?

1 Like

thanks vjFaLk

I am just plain confused.

I Got that this morning, so I said… heck with it, I am getting really good and setting up VMs and installing ERPNext. So I did it again. My 4th time this week. Got ERPNext installed had to install python this time. Worked fine got it up to the wizard. Didn’t go through the wizard. Installed and setup openSSH so I could connect to the files and edit them if need be. I was able to connect to it via Komodo. Great! Check my IP/Site again and I get Internal Server Error. So for grins I reboot the server and and now I am getting the same “Sorry! We will be back soon.” message that I did on the last VM I setup.

My question is this. What’s the best OS to install ERPNext?
I have tried UBUNTU desktop install and server install and CentOS.

I am going to try and read up at home, but would be nice to know which OS is BEST for ERPNext? Then I will focus on learning that OS. Now I can’t figure out why OpenSSH would be causing ERPNext to fail.

I am so excited to get into the development process, but I am stuck on the installation phase.

As always, thanks for any help!

Seems your supervisor is down, I guess when you restarted it didn’t turn back on. Supervisor is what manages all of ERPNext’s services. Run sudo service supervisor start and then give me the the output for sudo supervisorctl status if running the previous command didn’t fix the issue.

There is no best OS for ERPNext, Our installer works well on Ubuntu 14.04 to 16.04, CentOS 7+, Debian 7 to 8, so all of those are good options. It’s better if you get the latest stable releases in general.



Started that service and it was working. I wonder if it wasn’t OpenSSH that killed me, just the 1st reboot.
Once I started the service, it worked. Although, It failed after I rebooted.
I ran “sudo systemctl enable supervisor” to get the service to start on boot and it seems to be working now.

Thanks for your help vjFaLk!


It was definitely the fact that supervisor wasn’t being started on bootup :slight_smile: