Sorry! We will be back soon!

I had a nice stable instance of ERPNext running for a few months but the power went out this evening and now I’m stuck. Started my server back up, all Nginx apps were running without issue but ERPNext is giving me the:

Sorry! We will be back soon. Don’t panic. It’s not you, it’s us.

I’ve tried bench restart but get a cryptic message about being in edit mode instead of production mode…read around on the forums but am lost.

Any advice will be appreciated.


P.S. ERPNext v13

Sorry if not answering your problem.
I just want to comment on the message. I just got it today (for other reason).

The message says “it’s not you, it’s us”.
But since it is a self hosted: us = you = me… so I did panic :slight_smile:

Turned out my problem is bench setup nginx not updating conf after a ssl creation. So the sites can’t be accessed.

Thanks, yes, I agree. I am hosting a demo site so it’s not crucial but I’m in a mini panic as well. Once this turns into a functioning production site it will need to stay up and come back up in the event of a power outage (even if they are rare) so I need to know how to fix the problem.

I did install an SSL certificate after getting ERPNext up and running a few months back…maybe I have the same problem.

Thanks again

Well, I’m still experimenting and I’m not “back soon” :frowning:

It seems problematic a power outage (for whatever reason) would render the site so inaccessible…I’m sitting here banging away with lightening and thunder outside…power might go out again before I can figure this out…which will be a sign that I’m supposed to give up and go to bed. :slight_smile:


bench show-config

what is the output ?

Try a bench update or bench restart , note any warnings or error messages.``


Thanks, I’ve just run it and get:


My problem now is that I ran

bench setup nginx

and now I get a different error message. My SSL certificate seems to be corrupted or not correct so the browser won’t proceed.



Thanks, no error messages with “bench restart”


agree, fix Nginx issue first to ensure no error first, then back to troubleshoot frappe / erpnext.

I found you have rerun bench setup nginx, it will generate up-to-date config but will also overwrite any customize config being used.

I still not found a better way yet so each time execute that command, I will also recheck and compare what should I input back, like SSL cert config as well.


I give up :frowning: Going to bed…maybe I’ll make some progress tomorrow. I’m beyond the “Sorry! We will be back soon” message now…SSL not set properly it seems but why…it all worked without issue before the restart… Sigh… A bit frustrated that it can be so hard to get it up and running after a simple restart. :frowning:



Thanks…I’m burnt for today. Guess I’ll try and get back at it tomorrow when I’m fresh. Thanks for your help.



I’ve poked around a bit today and am lost. Nginx is running and serving other web apps without any problems. Redis is running and seems to be properly configured. I have the path to my valid SSL certificates set properly…but now, after last night running

bench setup nginx

My ERPNext is entirely inaccessible. I get a “cannot establish a secure connection” error when trying to access via my domain. The


output seems to indicate that it’s configured properly. After adding the ssl certificate path I get the following (with private information blocked out).

Does anyone have any suggestions as to how I can troubleshoot this? For example, bench commands that allow me to obtain more diagnostic information? Any help/advice will be most appreciated.


P.S. I do get the “bench is installed in editable mode” message but that is ok for now as this is a production demo. Or, at least I think that is ok…?

P.P.S. One more comment here and then I’m going to take a break. :slight_smile: In my sites-available directory (for Nginx) I see no reference to ERPNext…? I’ve forgotten how it was configured prior to the problem I’m experiencing here but it seems like there should be something, somewhere, pointing to ERPNext…no? I have 4 sites-enabled files all pointing to other little web apps and they all work flawlessly. The ‘default’ file seems to just be for port 80…so, this is probably a very ignorant question but, where is the Nginx config to make it ‘aware’ of ERPNext?

you seem lost of direction :sweat_smile:

we will try help , hope we can.

first, bench setup nginx will overwrite previous config as I mention, so first check should be the config file, the generated file should be ~/frappe-bench/config

check the content , at least the config is included ssl setting, then you should check nginx setting, if you have another web service in running, I assume you should has symbol link to ~/frappe-bench/config/nginx.conf for nginx to work.

if all is fine, then you may need post the nginx log for error troubleshoot.


Thanks, yes, I’m lost :slight_smile: But I’m somewhat used to being lost so it’s ok. :wink:

I checked ~/frappe-bench/config and can confirm that the path to my ssl certificate information is included.

In my Nginx config however, I don’t see a symlink to this file anywhere…which basically answers my question about how Nginx is ‘aware’ of ERPNext. I guess it’s not :slight_smile:

Wait…yes, there is a symbolic link in sites-enabled and it does, in fact, point to


Hmmm…something is off. Guess it’s time to check the Nginx logs.


P.S. Well, just did a quick check…I don’t see anything odd or helpful in the access.log or error.log for Nginx…hmmm

ok , how about supervisorctl status ouptut ?


Thanks…but I’m not sure I have the correct syntax. I tried

bench supervisorctl status

But got an error saying “No such command”

So, I tried simply

supervisorctl status

But nothing happened…I mean the command seemed to execute but there was no output…wait, do I need to include “output”…no, that doesn’t work.

Hmm, can you point me in the right direction for the correct command to use?

Thanks again for you ongoing support.


I think it should be sudo supervisorctl status nginx

Also maybe you can check the /etc/letsencrypt/live/ to see if your certs path/name are all correctly referred to (in the site_config.json, common_site_config.json, nginx.conf)
You can also use the command sudo certbot certificates.


Thanks, but that command gives me an “ERROR (no such process)” message.

Regarding the certs name and path, I have checked them and they all seem to be correct. Also,

sudo certbot certificates

Displays information for the certificates I have with their paths so I guess everything is ok there.

Oddly, however, supervisor seems to be either not running or incorrectly setup maybe…



sorry for my lazy

here is the sample output

or from the info now, I guess it may be:

  • multitenant config issue
  • or mariadb db connection issue
  • or bench update issue

for multitenant , em … I have not setup this feature yet , so no rich support can provide

for mariadb, can check any access log issue

for bench update, if major file(s) has changed, it would better to issue follow command as well:
bench build
bench clear-cache
bench clear-website-cache



Thanks again. Let’s see, I stumbled onto this post:

And noticed that I have the same problem (maybe it’s a problem?) in that there is no supervisor.conf file in home/myerpnext/frappe-bench/config

So I made a symbolic link as explained in the post above and then resetup supervisor.

But now, when I run supervisorctl status I still get nothing.

Am I supposed to be running it inside the frappe directory or inside the ERPNext directory? Or can it be run from anywhere…which is what I was assuming.