Sporking Bench: New tools for installing ERPNext

I sympathize with your frustration completely. Feedback like yours is the reason I began this project in the first place.

…so i finally managed to do a manual install. What a rigmarole!
and every bit of documentation I’ve found is lacking, out of date, or just plain wrong!

to top it off it turns out i neglected to use sudo when performing the pip3 install of bench… more drama… adding path’s and fixing permissions!

At least i’ve got a working instance now! Not that i can use it because I need to be able to tear down and repeat these instances with CI/CD.

As it stands I think bench itself does a pretty good job of what it’s supposed to do… it’s just getting the bloody thing working in the first place that is the issue. I may change my opinion as i gain more experience working with the tool, in which case I might check out your project again in the future.

I’m just about to start writing some docker-compose and ansible scripts to automate the steps I’ve taken to get it working.

I’ll document these and share with my repo with the community once I’m satisfied its working as intended.

queue breaking update release…

If you play around with Docker do contribute here.

I and Davide from community are maintaining it since few months now.

for production (immutable images) frappe_docker/README.md at main · frappe/frappe_docker · GitHub

For development container: frappe_docker/README.md at main · frappe/frappe_docker · GitHub

Docker contribution will only happen through community

1 Like

I installed one V12 instance with easy script on fresh VPS without a hitch. Next day tried one more installation on another fresh VPS of same configuration from same service provider. Ran into number of issues. After 4 days of trying with about 6-8 reinstall of OS got it working. And I have no idea which of the solution from this community worked. Felt like going on my knees and thanking god when I saw the message ERPNext has been installed. :grin:

1 Like

Will love for you to share these instructions with me if you don’t mind.

They’re lengthy, and currently hosted on my private wiki.
I’ll add a task for myself to convert the instructions into a blog article. Then I’ll post the link here, along with some other Weavlo stuff.

1 Like

Thanks. Will look forward to it.

you can join ERP Next chatroom on discord https://discord.gg/ReZy7dj

we can help each other share tips

see you there

Thanks for the update Brian. Ubuntu 18.04 LTS which was earlier supporting both 32/64 bit, now in the latest upgrade 20.04 LTS, guess supports only 64 bit. This is proving the major point which you earlier emphasized - 32/64 bit programs / prerequisites getting deployed in 32/64 bit OS. Couldn’t be a better timing for Ubuntu use case.