SSH is working - ping and http(s) not

After a restart from the Harddrive i can’t reach the Server via http(s) - “502 Bad Gateway - nginx”.
A ping get a 100% loss rate.
via ssh login everything is working.

Maybe interesting:
after ssh login i got the message “39600 failed login attempts since the last successfull login”
Last Login: a week ago.

Maybe someone here can help me to get the web access back?

you need to check if NGINX is running, run the following command:
systemctl status nginx

In the second last line it says something about invalid argument.
i looked at it → in “/run/nginx” is just a number “1148” - nothing else in the file - is that correct?

There is an error with the file.
Follow the steps in this guide and it will be fixed.

Check the open ports and make sure that 80/443 are available
ss -tnlp
Do you have a firewall? Maybe something like fail2ban has blocked access from your IP address because of failed login attempts (ie. perhaps someone has tried to hack your system?)

1 Like

I am currently still learning a lot, maybe you can tell me if this is correct.

Yes we use a firewall.
But it is completely preset, we have not edited anything yet, but when I look at it, nothing is blocked.

Should it look like the picture?
I no longer see an error message.
The page is currently still unreachable - same error message - “502 Bad Gateway nginx”.

what does your error/log file show
sudo tail -30 /var/log/nginx/<error_log_file_name>.log

Some good posts here

and here

on how to find/fix things

I understand that the handshake fails because of the version, but I can’t interpret it exactly.

I think you need to tweak the SSL settings of your nginx.conf

        # SSL Settings
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

There is a utility here that can assist you to create a “safe” config

Unfortunately, I have not yet been able to make any further successes - still not available.

Can someone please give me detailed instructions on how to solve my problem?

Possibly I can replace whole faulty folder simply from you?

The system is being rebuilt from the ground up.