Standard Reply - Any Jinja field entered brings error

I’ve been trying to use some of the Standard Reply features, and have had errors every time when using the jinja code feature to bring in field values. I have tried with different doctypes and fields. {{ }} even will produce this error. I don’t believe I have anything beyond standard that would be a cause to throw an error. I did encounter it a few months ago, and ended up forgetting about it, so I refrained from posting it to the github issues because I think it might be something locally if it hasn’t been an issue for anybody else. Does anybody have insight on using field value pulls for Standard Replies?

Traceback (most recent call last): File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 55, in application response = frappe.handler.handle() File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 19, in handle execute_cmd(cmd) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 36, in execute_cmd ret =, **frappe.form_dict) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 854, in call return fn(*args, **newargs) File "/home/frappe/frappe-bench/apps/frappe/frappe/email/doctype/standard_reply/", line 18, in get_standard_reply return frappe.render_template(standard_reply.response, doc) File "/home/frappe/frappe-bench/apps/frappe/frappe/utils/", line 50, in render_template return get_jenv().from_string(template).render(context) File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/jinja2/", line 989, in render return self.environment.handle_exception(exc_info, True) File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/jinja2/", line 754, in handle_exception reraise(exc_type, exc_value, tb) File "


I seem you have error in jinja template. can you share the template ?

Thanks, Makarand

Seemed like it. I tried copying the example that is shown below the form during creation, and apply it to sales invoice, and it threw the error… I also tried just ruling out the simplest request by using {{ }} and even that gave me an error.

Is there formatting that has changed since?

@superlack: Were you able to resolve this? I’m facing the same issue.

I hadn’t revisited it since posting this actually, but it’s been on my mind. If the examples in erpnext are producing an error though, I think the jinja formatting may need something additional