Stock Entry with Allow Zero Valuation Rate has been disabled

Hello everyone,

I setup ERPNext on My server. Now I create a Stock Entry. I want to set zero valuation But the Allow Zero Valuation Rate button has been disabled. I cannot click into.
What’s wrong settings up there?

Hi @sinhpntech,

If you haven’t checked then please check the documentation.

Thank You!

1 Like

Hi @NCP,

Thank you for your response.
I have checked the documentation. When setting up different source and target warehouses, I am unable to click on the “Allow Zero Valuation Rate” option. My intention is to simply manage the movement of goods within my warehouse system from warehouse A to warehouse B without considering their valuation. How can I achieve this?

Maybe try the Customize option to change Allow Zero Valuation Rate the default to checked?

On Purchase Receipt list find the Customize option, once open click on Customize Child Table and select Purchase Receipt Item.

Find Allow Zero Valuation Rate in the fields, and change the default from 0 to 1.

1 Like

Thank you @pmjd

I removed the Read Only Depends On by eval:doc.s_warehouse. And It’s working on.

Thank you so much


Just to know that why we put eval:doc.s_warehouse in the read only depends on?

Hi @Sanath_Udayawansa2,

It’s a default set in the field of Allow Zero Valuation Rate.

How will it work?

Ticking on ‘Allow Zero Valuation Rate’ will allow submitting the Purchase Receipt even if the Valuation Rate of the Item is 0. This can be a sample item or due to a mutual understanding with your Supplier.

Different Source and Target Warehouses can be set for different Items.

More details for please explore the Stock Entry Documentation.

I hope this helps.

Thank You!