Stock Ledger Report is Blank!


I’m facing an issue in my account where the Stock Ledger Report is not returning any data even though there are stock ledger entries. I have two companies setup in the account but this issue only affects one of them! I’ve checked permissions and everything seems to be in order. There are no restrictions showing at the bottom of the page and there are no errors in the console log

Any help here will be greatly appreciated


Hi All,

Does anyone have any idea what could be causing this? Would really appreciate if someone could point me in the right direction


I just made some more discoveries which may be linked to this issue. I observed that the last Stock Entry (Material Receipt) created for this company did not have any accounting ledger postings created even though it was submitted! Upon further investigation, I noticed that no serial numbers were created for any of the items received in that Stock Entry even though they are all serialized items!

I tried cancelling and amending but still the same outcome… no accounting entries and no serial numbers created. I then created a new Stock Entry for that company with one serialized item and submitted it. The accounting entry was generated but no serial number created (even though a pop-up message said it had been created!)

Anyone have any idea what could be going on here?


Any chance that Serial Nos. are not visible to you due to permission restriction? Is this issue occurring in the hosted account?

Hi @umair

Thanks a great deal for your help. The permissions somehow got changed after the update. I’ve updated them and the Ledger is visible now

Thanks again!