Stuck on bench build of frappe only

I updated some code in web_form.css, I know that changes get applied once we build it.
It worked fine on my local machine but gets stuck on the server when its time to build the web_form.css
Can I know where can I find the build logs? to figure out the issue

A hint, possibly, until someone more knowledgeable replies.

There are some things permitted in production mode but not in development, and vice versa.

You may have to switch from production to development, make the changes, then switch back.

Warning. I haven’t tried this but you might want to look into it.

yes this is how it got resolved just now, I saw a comment somewhere that bench should not be running while bench build is executing no idea why, on production there was no other way to stop it other than disabling production.
Do you know some other way to stop the bench in production build and restart?

Did you try:

sudo supervisorctl stop all;

Do your stuff, then:

sudo supervisorctl start all;

No I didn’t, I will then next time

this did not work, bench build got stuck again

It seems it’s time for you to share the logs produced by the failing command.