Stuck on Data Import In Progress Status

Hi everybody,

Now, i’m stuck on a In Progress bug…

I’m trying to import some Material Requesta data, to upload status in a batch, but it remains stuck…

Is there some way to reload it, delete it, or to fix it?



bench setup requirements
bench setup socketio
sudo bench setup lets-encrypt {your-site-here}
sudo service supervisor restart
sudo service nginx restart


I had this:

You cannot setup SSL without DNS Multitenancy

The “In Progress” still here, but now, I can do others… Thanks!

You can enable the multitenancy

bench config dns_multitenant on

I am stuck on an import in progress status. Small file. Using the erpnext website. Before this I had recently been uploading often and the time it takes to import has started to slow down a lot.

I have recently uploaded around 15700 items and their price list.
I had the same issue but the bug is on uploading the csv or xls file.
What i did to fix it.

Open new import form
Select the doctype
Attach file on the left side panel not using the attach button in the doctype.
Then press attach button and select the attached file.
Then start import.

That worked flawlessly for me.

Try it. Hope it works for you.

I will try it when I get to work. Why do I have to use this work around and if it works what happens to the import in progress that is stuck. Will it eventually finish and undo anything that has changed after I used the work around?

Thank you

The in progress that is stuck sound to be an js graphic issue.
Most of the time it is doing the work in the background.

Use a different and check the backgound job list. if the import is completed you will see all the import lines with green dots, if successful.

That did not work. I was able to delete it.

Did you check background jobs in progress when you started the import process?

How much is the ram you’re using on your server ?

I am using the ERPNEXT site and I have about 60% of the limit left. I have deleted as many logs and attachments as I could to free up space. I was able to delete it and tried again with a smaller file and it worked.
Thank you.

Remove “Opening stock” col from Excel sheet it will work great.