Stuck on E logo. Site not loading after login

I’ve seen many discussion on this issue but no solution worked.
I’m facing this issue only on mac desktop. Its working fine on ubuntu atleast.

Uncaught SyntaxError: Invalid or unexpected token
list.bundle.4C4MEGCY.js:40 Uncaught TypeError: Cannot set property 'listing' of undefined
    at list.bundle.4C4MEGCY.js:40
    at list.bundle.4C4MEGCY.js:1673
(anonymous) @ list.bundle.4C4MEGCY.js:40
(anonymous) @ list.bundle.4C4MEGCY.js:1673
form.bundle.KI34TQU6.js:14918 Uncaught TypeError: Cannot set property 'address_list' of undefined
    at form.bundle.KI34TQU6.js:14918
    at form.bundle.KI34TQU6.js:17258
(anonymous) @ form.bundle.KI34TQU6.js:14918
(anonymous) @ form.bundle.KI34TQU6.js:17258
controls.bundle.YRCRVQHV.js:14932 Uncaught TypeError: Cannot set property 'get_data_uri' of undefined
    at controls.bundle.YRCRVQHV.js:14932
    at controls.bundle.YRCRVQHV.js:15995
(anonymous) @ controls.bundle.YRCRVQHV.js:14932
(anonymous) @ controls.bundle.YRCRVQHV.js:15995
report.bundle.QQSSW5DY.js:790 Uncaught TypeError: Cannot read property 'Factory' of undefined
    at report.bundle.QQSSW5DY.js:790
    at report.bundle.QQSSW5DY.js:1358
(anonymous) @ report.bundle.QQSSW5DY.js:790
(anonymous) @ report.bundle.QQSSW5DY.js:1358
erpnext.bundle.WWZTFJAL.js:1 Uncaught TypeError: frappe.provide is not a function
    at erpnext.bundle.WWZTFJAL.js:1
    at erpnext.bundle.WWZTFJAL.js:214

This happens a lot on Mac especially if you’re using Safari browser. Try using
Firefox or Chrome on Mac and everything will be fine.

Hi @flexy2ky,
I checked on all Chrome, firefox, safari. Its happening on all of them. The screenshot is from chrome.

Have your tried running bench setup requirements and then bench build ?

I did bench build multiple times.
Can you please specify which command you mean by “bench setup requirements”

bench setup requirements
this is a command like bench build …try this and run bench build again after this.

Thanks @shadrak98
I’ve now done a fresh install and its working fine now.
But I don’t think this would solve the issue as its just installing the apps which were already done and I did bench build multiple times.

Hey guys,
Can confirm that this is working just for once and after that the specified issue is happening. This is on macos.
Can someone please suggest a permanent solution for this?

Can anyone please suggest something here.

Also experiencing the same issue, I’ve reported my issue here:

Do you have a minification process, such as Cloudflare’s auto minify feature or a proxy that removes sourceMappingUrl values from the end of the JS bundle files?