Stuck with DigitalOcean Installation of ERPNext

Hello Everyone,
I am trying to install ERPNext on a DigitalOcean Droplet (1GB, 25GB Disk, FRA1, Ubuntu 16.04.4 x64).

I am following those setup instructions: Easy Install ERPNext on DigitalOcean.

I have tried to install around 10x by now and the installation is always stuck at:

TASK [bench : python3 bench init for develop] **********************************
^CTraceback (most recent call last):
File “”, line 420, in
File “”, line 122, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 338, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 536, in check_call
retcode = call(*popenargs, **kwargs)
File “/usr/lib/python2.7/”, line 523, in call
return Popen(*popenargs, **kwargs).wait()
File “/usr/lib/python2.7/”, line 1392, in wait
pid, sts = _eintr_retry_call(os.waitpid,, 0)
File “/usr/lib/python2.7/”, line 476, in _eintr_retry_call
return func(*args)

What am I doing wrong? Would appreciate your support.
Thanks and Best regards,

I don’t think you’ve posted the whole of the error so its difficult to advise until we see this. It’s interesting that bench is talking about python3 but your python install is 2.7 . This may be part of the problem. I would install with python 2 if using stable production version for now. V11 in Staging has been tested far more with python 3 …

Hello Julian,
thanks for your response. This is the error I am getting when I abort the process manually. There is no error as such during the installation. Its just stuck at “ASK [bench : python3 bench init for develop]”. I have left it with this task for a few hours but nothing changed - no progress. I aborted the operation. So I guess in my case the easy/quick install does not work?

The easy installation script is not working . i am facing the same issue

1 Like

Thats a pity, thanks for the insight Santosh.

Maybe, you should install it in production mode. Easy installation through develop mode needs a lot of fix. I believe.

1 Like

Production mode doesnt work either, there is a whole bunch of errors coming up.

Hello, flooberhofer

Try this installation process.

Let me know what is the result.




Damn, this actually worked. You are a genius, thanks a lot Ivan :slight_smile:

1 Like