Submittable Doctype does not show Submit Button


I create a custom doctype for a requirement of mine. This doctype is
Is Submittable and this automatically creates a new field called “Amended From”

When I got to the form, I can now see “Draft” next to the title. Which is what i wanted.
But the Save button never makes way for the validate button. At first, I assumed this was because I may have left an is_dirty flag on some custom scripts I am running on this page. I went through the full document and clean up any unnecessary code. This can be checked when I click Save (1) a popup shows up saying “No Changes in this Document” (2). This conforms that my script is not adding unnecessary changes to the document that requires me to save first.

I am completely dumbfounded by this. I tried Workflows and it does change the save button to something else. But it’s not quite what I need. Is there something I am missing from this?

Hi @ablishek,

Please go to your doctype and if you have not applied for a check then apply to check in the Permissions Rules section.

Maybe would resolve your issue.

Thank You!


Hi @NCP,

Thanks for your response, and yes I have checked this. Since I’m the main user I have checked all user roles (I am systems manager, sales user, sales master user, etc). For sales master manager it has the ability to submit, but not for sales user (and I am both)

I was to assume that erpnext would take the highest available role and allow me to submit like it does with sales order.

Hi @NCP ,

Ok you were on the right track. Ty here are two places for Permisions Role: 1) in the Doctype and 2) in Permisions Manager.

For some reason only the settings first created in the doctype were carried over to Permisions manager. And originally I had set systems manager for no submit. Even though I would update the value in the above mentioned doctype that would be updated in role Permisions manager. This is what caused the issue.

To solve I had to go there and manually give the settings I wanted. This may seem like a bug but will test it out some more before putting it on GitHub.