Successful installation on Debian 9

I spent some time installing ERPNext using the easy install script. Unfortunately with many, many errors.

I was now able to successfully install ERPNext.

Here is my story:

initial situation
Blank Debian 9 with pre installed Python2.7 & Python 3.5


  1. Create non root user with sudo privileg (in my case “Debian”)
  2. wget
  3. sudo python --production

first error

    ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’,
    ‘–become-user=frappe’]’ returned non-zero exit status 2`

root cause

ansible-playbook 2.8.5
  config file = None
  configured module search path = ['/home/frappe/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/local/lib/python3.5/dist-packages/ansible
  executable location = /usr/local/bin/ansible-playbook
  python version = 3.5.3 (default, Sep 27 2018, 17:25:39) [GCC 6.3.0 20170516]
No config file found; using defaults
ERROR! the playbook: site.yml could not be found


  1. I’ve cloned the frappe git repo manually again into /home/frappe/.bench
  2. retry sudo python --production

second error

"template error while templating string: expected token 'end of print statement', got 'b0ab02aa6e17346af2f14ed0de807376de475ba90e1db3975f112fbd20bb'. String: {{ 1140b0ab02aa6e17346af2f14ed0de807376de475ba90e1db3975f112fbd20bb if ansible_architecture == \"x86_64\" else 5b2d15e738ac479e7a8ca6fd765f406c3684a48091813520f87878278d6dd22a }}"


  1. Changed line 75 of main.yml (located in /home/frappe/.bench/playbooks/roles/wkhtmltopdf/tasks) to checksum: "sha256:{{ '1140b0ab02aa6e17346af2f14ed0de807376de475ba90e1db3975f112fbd20bb' if ansible_architecture == 'x86_64' else '5b2d15e738ac479e7a8ca6fd765f406c3684a48091813520f87878278d6dd22a' }}"
  2. retry sudo python --production

and here we go: Bench + Frappe + ERPNext has been successfully installed! :clap: :clap:


Thanks for sharing this… while solution might be far-fetched, should be workaround. Should a solution fix this int the respective scripts (why is the pull not working by default, and the checksum seems to be wrong)…

There’s a PR under review currently to fix this issue.

Might I request a simple docker image for fools like myself?

1 Like

@nicholas :

I really don’t follow your solution when you say "I’ve cloned the frappe git repo manually again into /home/frappe/.bench.

1 Like
  1. I’ve cloned the frappe git repo manually again into /home/frappe/.bench

Can someone explain what exactly is meant here? I am having the same issue as well.

1 Like

This is the error I get:

Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2.


It finally worked after I tried again on a new clean Ubuntu 18 server. I’m not sure why since I did pretty much the same things while following the easy install readme (at least I think I did). I just didn’t get the error this time… Weird