Sudo supervisorctl status - redis not working

frappe:frappe-web RUNNING pid 18770, uptime 0:00:51
frappe:frappe-worker RUNNING pid 18769, uptime 0:00:51
frappe:frappe-workerbeat RUNNING pid 18771, uptime 0:00:51
redis-cache FATAL Exited too quickly (process log may have details)

Could you tell me what to do in this case? I did the upgrade and run the restart nginx and supervisor but still…
Thank you!

Could be an issue with very old redis version,
from the frappe-bench dir,
what is the output of

tail -n20 logs/redis.log

tail -n20 logs/redis.log
No output!!

For your info:
DO with Ubuntu 12.04.5 LTS (GNU/Linux 3.13.0-32-generic x86_64)
Thank you pdvyas!

Should I install a new redis version? But I will need help about redis config in ERPNext…

Also in this case the system is working but the screen is white…

from the frappe-bench dir,

redis-server config/redis.conf

Reading the configuration file, at line 4

‘auto-aof-rewrite-min-size 64mb’
Bad directive or wrong number of arguments

Looks like you’ve redis 2.2

redis-server --version

As a quick workaround, you can remove the offending lines from the config file and try again. (could be more than one options). Once the redis-server starts running, quit it and run sudo supervisorctl restart all

1 Like

Thank you! pdvyas, no more error about redis.
Only: redis-cache: ERROR (abnormal termination) after supervisorctl restart all.
White screen at ERPNext desktop still an issue…

Can you try running bench update?

I mean, I see the modules and all is working fine but background is not colored but white…

I have the exact same issue