Supervisorctl restart frappe: frappe: ERROR (no such group)

fresh install on fresh ubuntu 20.04 followed the guide for manual install

supervisorctl restart frappe:
frappe: ERROR (no such group)
when I run bench update


Try: bench setup supervisor then update again. You may want to look at these instructions as well:

it required me to run sudo bench setup supervisor

None of my instances require sudo to execute the command. It may be that the installation needs to be reviewed or a different method tried.

hmm I followed it verbatim. do you see anything in the steps that are wrong?

If you did step 16 after installation it might have something to do with it.

what happens if you did install with sudo?

The docs have the pip3 install of frappe-bench without sudo , the link you have referred to uses sudo. That may be what the problem is though I think I installed from pip3 with sudo and do not have the supervisor problem.

For anyone facing this issue, simply downgrade bench version to 5.12.0 using pip3 install frappe-bench==5.12.0 This issue seems to be tied to later bench versions and this has seemingly not been fixed several versions after.


Please check your Bench version

bench --version

If it is above 5.12.0 then please downgrade your version to 5.12.0 using the following command

sudo pip3 install frappe-bench==5.12.0

There is something causing issues with the latest version of the bench. So as long that is not fixed you can use the old version.
I hope this helps.

This happens when symlink isn’t created.
Follow this to manually setup supervisor: Setup Production

try this