$ Symbol is not highlighting


I want to include the Dollar symbol " $ " in the print format for the displayed amount in the fields “Total”, “Finance 6 Percentage” and “FOB USA”.

How can I do that?

Thanks & Regards,


You probably need to escape the $ symbol

I didn’t get you.

In the code you used to display the value - how did you specify the output format? If you share how you did what you did, I’m sure someone can help you

I didn’t write any code in the print format.

OK - but with the information you have shown, we can’t see which module you are using or getting the error on. It makes it very difficult to help you

I have created a new doctype called “cost template” which comes under setup module.

The data type for those fields have been set as currency in the doctype.

Under your settings, look at Global settings - where you set your currency - there is an option to “Hide Currency symbol”. I think it should be blank to display the currency.

Yes, it was blank.

When I clicked on that option, it showed option YES or No.

So, I selected NO and saved it, but still the symbol is not comming in the print.

I can only suggest a

bench --site your-site-name clear-cache

Set each field option Company:company:default_currency

I tried as you said setting each field option as Company:company:default_currency, but still it is not working.

Have you reloaded after change? what is your print format, is it custom?

Yes, i have reloaded, it is not a custom

I’m not sure what caused the problem. can you show me your print format and those three fields in Doctype (like your screenshot above)?