Text Indenting on Text Editor Field

The indenting on Text editor fields is not retained on clicking Save.

Steps to reproduce

  1. Create terms and conditions and indent a line using
  2. Save the Terms and Conditions template

    At this point, the indentation is lost

Is this a Bug or am I missing some config/setting?

Has anyone faced this ?

Yes this is an issue (maybe you can report it on GitHub), however if you leave it like below it will appear something like below on your print format

Print format

Thanks for your help.
Will create a Github issue and post here.

Are there hooks, so it can be confirmed if it’s a frontend editor bug, or server-side bug?

I have encountered this in other software that uses TinyMCE from both Frontend and backend.