The Hidden fields are showing in the masters

In the Item Doc Type the series is set as hidden

In the Item Customize form the series is set as hidden
in the Item master the field series is shown.

Seems like a bug. Can you put it up on GitHub issues.

Hi Thankyou,… This issue is occuring in all the masters.

Naming Series is a special field and hidden settings won’t affect it. It will be affected by how you are naming your masters.

Hi Thankyou, when changing naming series to code it is hidden.