The link within a notification email is wrong

I have configured the bitnami image on an internal VM to the company and installed hrms.

The email notification works as shown however the link on “open now” takes me to: http://'http:/app/leave-application/HR-LAP-2023-00005

which gives me a “this site cannot be reached page”

how can i modify this link to work correctly?

Thank you in advance

Can you try to add a “site_name” settigns in the site_config.json ?

I don’t know why but unfortunately bitnami images have some problems with links.

like this?


Like this: Barcode Printing on ERPNext - #11 by TurkerTunali

added i’ll try another new test leave now. thank you :crossed_fingers:

doesn’t like that

this was just visiting the site after applying changes to the site config file.

How is your site_config and common_site_config files looks like?
And how do you access your site? IP or URL? Is it local vm?

internal local IP address as displayed above - yeah local vm

common config:

After setting the host name as local IP like in the site_config, you may need to issue “bench setup nginx”, “bench clear-cache”, “bench reload”.

the link in the email changed to http://%2710.0.0.178%27:8000/app/leave-application/HR-LAP-2023-00006 which is still the site cannot be reached …

then …

bench clear-cache
Please specify --site sitename
bitnami@debian:/opt/bitnami/erpnext/frappe-bench$ bench clear-cache --site erpnext
Usage: bench clear-cache [OPTIONS]
Try ‘bench clear-cache --help’ for help.


bitnami@debian:/opt/bitnami/erpnext/frappe-bench$ bench reload
Usage: bench [OPTIONS] COMMAND [ARGS]…
Try ‘bench --help’ for help.


bench --site erpnext clear-cache

that worked but bench reload still errored afterwards

checking the email queue now this is the link ‘http://‘’:8000/app/leave-application/HR-LAP-2023-00007’

which is still a broken link

accessing erpnext in the browser is viewable at so we’re getting closer

If ERPNext is working then Nginx port should be set correctly but I am not sure how links are getting port 8000.

You can try to set the port again.
bench set-nginx-port site-name 80
bench setup nginx
sudo service nginx reload
sudo service nginx restart

Then clear-cache and restart it.

i ran these commands:

then i now get this

so the port issue is gone but there’s a = in there breaking the link

Unfortunately, production setup should be handled seperately.

that shouldnt affect the broken link though? :thinking: