"There were errors" - Trying to setup new site

Should you want to revert back to Production

Here is what I did:

frappe@erpnext:~/frappe-bench$ sudo supervisorctl reload
Restarted supervisord
frappe@erpnext:~/frappe-bench$ sudo service nginx start
frappe@erpnext:~/frappe-bench$ sudo bench setup production frappe
supervisor.conf already exists and this will overwrite it. Do you want to continue? [y/N]: y
Port configuration list:

Site site1.local assigned port: 80
nginx.conf already exists and this will overwrite it. Do you want to continue? [y/N]: y
No config updates to processes
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful


Was anybody able to resolve these issues? I have been facing it for the last 1 week, and haven’t been able to resolve it even after formatting the disk, and going back to Ubuntu 14.04.

Only message is “There were errors.”


Hello @UmaG,

This issue hasn’t been resolved yet (to my knowledge), see here. But I have been able to subvert it (I think) by updating to V8 of ERPNext.

Thanks @ratskin for the response.

When I installed ERPNext, it installed Version 8 only, but is still giving the same errors… :frowning:


Is there any updates on this?,

Yet another connected post: [Mar-2017] Showing there were error during setup ERPNext

One more: Setup Wizard : Error

Maybe related to Travis CI - Test and Deploy Your Code with Confidence

Guys this resolved my issue Setup Wizard : Error - #2 by navdeepghai


Trying your solution now. Will update with my result.


Nup. Not resolved for me.

[ ] Add a few sample records
[ ] Setup a simple website for my organization


Did you try to install version 8?, This is still there in version 7 i think…

1 Like


What about you?, have you tried to complete the setup after unchecking those two option?.

Thanks for the response @salim. I tried the resolution given in the above link and it worked.

Thanks :slight_smile:

@salim thank you for sharing that post and thank you @navdeepghai for posting that solution.
Once I upgraded to v8 it worked for me.


1 Like

It did not resolve the issue, still stuck with same issue. Please suggest.

Unchecking has not resolved the issue for me either

@RWEMA_Aimable, @Aash_Kothari

What version are you using?
I’m pretty sure I was using V 8.0.7

Try unchecking ‘we buy this item’ and ‘we sell this item’. That worked for me

I just did bench update so I am running V 8.0.9 still the same error

This problem might happen for http request time out.

To increase http request time:

bench config http_timeout 600

If not work then reinstall your site again

bench --site [site name] --force reinstall