Throttled while insert data continuously

i am running a patch for my apps.
The patch worked as i’d like, then after some point my patch give me an error. Like this

*NB I ran this on bench console.

Then i wait several hours, then i did some patch again, then some data inserted and “Throttled” error comes up again.
I try bench reboot 0 and didn’t solve the problem.
I look into server load and it’s not high.
Anyone has any clue?

What kind of data you are trying to insert using a patch? Please do share a code snippet and calling mechanism.

Have you tried the Data Import Tool?

Thank you saurabh6790 for your response, i try to migrate from old server to frappe environment. Therefore i use requests on phyton to fill the data.

Basicly, i take response from old server loop it, convert it to json then insert data using
doc.insert and frappe.db.commit

btw I don’t think Data Import Tool be possible right now.

The best approach is, restore a backup to a new instance from the old instance.

If versions are different on both server, then run bench migrate after restore.

Oh sorry, to begin with i don’t have any access beside API that given to me nor my team and the old server not running frappe :joy::joy:.
Thanks for the help though. I guess i will wait the new server to “cooldown”.

Hi guys, i found some solution here, just changed on core/doctype/user/
Just comment the line on there.

my mistake:
i use try except so i can’t read the error trace. :cry:

You actually do not need to comment the code, instead just do frappe.flags.in_import=True before your insert method. That way line 1032 will just evaluate to True. And therefore won’t reach to the throttle code 1035.

1 Like