Top bar search not working

The top bar search is not working (or maybe I don’t understand WHAT it is supposed to search for).

Here are two screenshots: One with the top bar search not returning a match, and a search result from the “products” search returning a match with the same search text.

ERPNext: v10.1.75 (master)
Frappe Framework: v10.1.68 (master)

-Is it only me who has this problem?

Maybe not, but it is hard to say exactly what may be going wrong. You have obvioulsy altered your system since the blue ERPNext logo no longer appears on the screen in the upper left corner. So that tells me that you may have also altered other parts of the system.

We really wouldn’t know where to begin without being familiar with just how much your system is altered from the core. This is probably why you are not getting much help. There is just no enough information.


-Do you know how to change the logo? Because it seems like you think that I “altered the system” as if I changed the code, which I haven’t.

When you say “We really wouldn’t know where to begin” and “This is probably why you are not getting much help” maybe should be edited to “I really wouldn’t know…” and “I am not able to help because I have no idea why this is happening”.

This is how it is done from the UI, but I wouldn’t know how you imply that doing that has anything to do with the top bar search not working.

I did ran a search for “Adaptive” on Faris’s instance at and got the expected result. But yes, the website search surely needs much improvement - you shall post an issue on GitHub.

How did you search the top bar search if there is no top bar search in Did you enabled it to test it? What is the administrator user and password in order for me to test it too?

Thanks for taking the time to test it yourself

Ah… my bad, I tried the product search instead.

Hi, did you get solutions on this?

Hi Brian.

I am still using the following:
ERPNext: v12.1.8 (version-12)
Frappe Framework: v12.0.18 (version-12)

and well, it does return a result if you type the EXACT match. I tried with % and * to see if I got a LIKE match, but no results returned.

Hi CostaRica,
I had the same issue, i have designed the website page with custom html, and added a form that search item listed on a website, initially the form action was set to “/search”, i changed that to “/all-products” and changed the input name to “search” instead of “q”.
Hope that will work for you too.

1 Like

I have the same issue with v13.12.1.

In “Website Settings” screen, I click “Include Search in Top Bar” and a search field with be visible in the header. When I enter a product name in that field, no results are returned, even if I use the exact product name.

The default “Search for Products” field that displays in the body of the page works very well.

I also tried to search for contents in a web page and a blog. But still no results were returned.

I have the same issue with 13.18

I tried to search for Job Openings by either using keyword within job description, job title, and there is no search result.