Translation portal registration not working

Hi, I tried to sign up to ERPNext translation portal here and did not received verification email for three days. It displayed message that registration was successful and email was sent, but nothing arrived until now. When I try to sign up once again, it says that I am already registered. I also tried get password via Forgot password dialog, but no success, it displayed message that email was sent, but nothing arrived. I have whitelisted domains and in antispam, from discussion portal here emails work correctly.

Any help with this issue?

Hi martin42

Just now I registered on, the email arrived in less than a minute. Basic login in and log out ok is responsive for me.

Here’s a similar report of login woes with no word from Frappe or rmehta - I can appreciate they have lots to support ERPNext Translator does not work properly - #9 by vrms

Two suggestions -

  1. if you have a paid cloud service try

  2. Identify the repos and upvote that issue - it does not seem to be this one!?
    Issues · frappe/translator · GitHub

good luck

Hi clarkej, thank you for a suggestions. I do not have paid service, I only wanted to contribute to the translation.
Maybe it only does not like my email, or emails from our country, I do not know, but now I am trapped, I am not able to create new registration, because it says I am already registered, but I am not able to login, as I do not have verification link and retrieving password via forgotten password dialog also does not work…

Yes that service needs attention to avoid cases like yours.

Unfortunately that discourages folks who wish to contribute.

I can’t say where to report that issue not here either it seems Issues · erpnext/foundation · GitHub

If you can’t find your issue reported then add it to whatever one you prefer say Issues · frappe/erpnext · GitHub

I will try to find where to report it, but it is strange that nobody cares about it here…
Thank you for your effort clarkej.

Frappe needs our support - it’s easy to overlook how much they have on their plate to support Building Culture at Frappe. In the last six months, we have really… | by Rushabh Mehta | Medium

Update: registration does not work with email address with my TLD (.cz), with for example gmail accounts it works OK. It is really strange, because for example to this forum registration with .cz mail address works OK.

This post may help Https:// can't login? - #3 by jodeq