Trouble Installing ERPNext w/ Vagrant - SOLVED

Hey everyone,

I am following the installation instructions here GitHub - frappe/erpnext_vagrant: Vagrantfile and Bootstrap for creating a dev environment for ERPNext to get a dev environment set up. I got to step 4 in the setup and realized I do not have a /vagrant directory.
Where and how do I get that?



Hello Tristan!

Vagrant is installed on a folder called “HashiCorp” by default.
However, why do you need this folder?

Best regards.


Ah, found it! According to the instructions, I am suppose to modify some files in the /vagrant/frappe-bench/ directory which I also do not have.

I see now that you mean the folder inside the box (I was focusing on the step 4 of installation).

To access to /vagrant you need to connect to the machine with SSH as shown on the instructions, after that, you can access to the folder /vagrant/frappe-bench/ just with the command “cd /vagrant/frappe-bench/”.

I do not have the frappe-bench directory.
Am I to install that separately?

This directory should be created already on your box. Can you send me the list of folders of your vagrant box? Just run the command “ls” after running vagrant ssh.

all I have is
in the /vagrant/ directory, I have

Strange. I just installed to check and I have this folder on my box.

Could you walk me through your installation process?

I just followed the same steps from the github link.

The list of folders you passed previously is from a Windows directory?

I see.
Could it have to do with the way I ran init vagrant?

and those folders were what were inside my /vagrant/ directory though they also seem to be the files that are in my windows documents/github/ directory.

How come your installation is missing the erpnext_vagrant directory?

These folders are created when you run “vagrant up” for the first time. The box is configurated and Frappe and ERPNext is installed on the system. Maybe you had any kind of error during the installation that didn’t set up Frappe/ERPNext, but I am not sure.

Yes, exactly. Inside your local Windows folder /erpnext_vagrant/ should be the same files as in your /vagrant/ on the box.
So, just to check, if you enter on your Windows folder documents/github//erpnext_vagrant/ can you find there frappe-bench, bench-repo, etc.?

I do not have frappe-bench.

I have the bench-repo because I cloned it from git manually.

Then I think something went wrong with your installation. All these folders should be automatically created when running “vagrant up” as I said, it is not necessary to clone them.

If it is necessary for you I can post the exacted steps I made with all commands.

I will uninstall vagrant and retry the process.

If you could do that, that would be fantastic!

Thanks again for your help. It is very much appreciated.

No problem! So these are all the steps I followed (all using the Git Shell):

  1. git clone GitHub - frappe/erpnext_vagrant: Vagrantfile and Bootstrap for creating a dev environment for ERPNext erpnext_vagrant
  2. cd erpnext_vagrant
  3. vagrant up
    This will take some minutes (for me it took about 15 min), it will download the box and will download Frappe and ERPNext and install them as you will observe on the output. Pay some attention from this output if something goes wrong, it shouldn’t.

When it will finish the installation:
4. vagrant ssh

Once you are connected via SSH you should find the same folders as I posted on the screenshot:
5. cd /vagrant/
6. ls

On Windows folder you should see also the folders:

1 Like

Thank you!
The issue was I was not running vagrant up inside the git repo.

You are welcome!
I am glad it was fixed.

1 Like