Ubuntu install created bench issue

I updated Ubuntu to 20.04.4.
The issues with the bench started, I read numerous forms. The conclusion I came to was it had to do with updating python. I tried to reinstall the bench but even after doing so using “pip install frappe-bench”. I still get the error from any bench command that “the bench distribution was not found and is required by the application”. Was wondering what the best move forward was

Try installing python3-pip , then sudo pip3 install frappe-bench. If bench gets working, ERPNext can be migrated to python3.x

I have python3-pip as the newest version (20.0.2).
If I attempt to install frappe-bench I get pkg_resources.DistributionsNotFound: The pip== distribution was not found and is required by the application.
Bench is still not working

Try: sudo pip3 install pip --upgrade

I get the same message about the distribution not being found

What does apt-cache policy python3-pip and python3 -V return?

python3 -v returns a LOT of output, anything in particular?

python3- V (large V)

also what do apt-cache policy python3-distutils and apt-cache policy python3-setuptools return

Python 3.8.10

Installed: 3.8.10-0utuntu1~20.04
Candidate: 3.8.10-0utuntu1~20.04

Installed: 45.2.0-1
Candidate: 45.2.0-1

Sorry , unable to reproduce with same OS and python3 versions. Make sure python3-dev is installed.

I have the newest version (3.8.2-0ubuntu2)


May we see the complete output of the command that produces the original error?