Unable to access ERPNEXT anymore

While I was doing some tests to fire out my email problem, I created a bigger problem.

For an unknown reason I decided to switch from production to developpement.

Now I’m not able to access my erpnext website anymore.

If I run sudo supervisorctl status
frappe:frappe-web RUNNING pid 3416, uptime 0:00:07
frappe:frappe-worker RUNNING pid 3415, uptime 0:00:07
frappe:frappe-workerbeat RUNNING pid 3417, uptime 0:00:07
frappe-async-worker RUNNING pid 3413, uptime 0:00:07
frappe-longjob-worker RUNNING pid 3414, uptime 0:00:07
node-socketio RUNNING pid 3412, uptime 0:00:07
redis-async-broker RUNNING pid 3406, uptime 0:00:07
redis-cache RUNNING pid 3407, uptime 0:00:07


I was able to make the site run again temporary with a sudo bench start but I needed to stay connected because as soon as I hit ctrl+C it stop to work.

and if I try again to do a sudo bench start I have this error:
20:18:06 redis_async_broker.1 | [3496] 08 Feb 20:18:05 # Opening port: bind: Address already in use

Any idea what can I try?


Read Production Deployment section

I read and tried everything and still unable to access the web interface.

after I did everything, I’m still unable to access the web interface and I dont know what else to try. My last solution is start from scratch and reload a dropbox backup

have you tried:

~/frappe-bench/$bench start


@Samuel_Gervais , Try to start your setup using serve command, refer following link for that -

I can do a bench start, but I need to be sudo and if I do that, bench start in my ssh session this means if I close the ssh session or if I press ctrl+c bench stop and btw the web interface doesnt work.

if I do a bench serve I have this error.

  • Running on (Press CTRL+C to quit)
  • Restarting with inotify reloader
    ^Csam@vps47435:~$ Exception in thread Thread-2 (most likely raised during interpreter shutdown):
    Traceback (most recent call last):
    File “/usr/lib/python2.7/threading.py”, line 551, in __bootstrap_inner
    File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/watchdog/observers/api.py”, line 237, in run
    <type ‘exceptions.AttributeError’>: ‘NoneType’ object has no attribute ‘Empty’

And while I’m doing all this the web interface doest work.