Unable to access site on AWS EC2

Hello everyone. I have installed frappe bench, erpnext and created a site on an AWS EC2 instance. When I run “bench start”, the building completes normally and I get the links to the site. I am using “http://my_public_ip:8000” format to try and access the site but it is not working.
I have also included the port 8000 in the security group inbound rules. But I am still not able to access the site.
I have set said site as the default site for the bench too. But still nothing. What am I missing?

1 Like


It may help to provide a few details. What type of EC2 instance and what tools you are using to test the connection, for example. Is the instance reachable by ssh?

Hi @smino
I’m using a t3.micro ec2 instance. Yes, it is accessible via ssh, but I’m connecting via their online terminal called ec2 connect.

In the terminal try: curl localhost:xxxx , replace xxxx with the port the host is running on and make sure the site is running. If your outside browser can’t connect because it times out, then it’s likely a firewall problem.

Hi. Still nothing. I can’t run the command while the site is running because the instance doesn’t let me run two terminals. However, I ran “curl localhost:8000” when bench wasn’t running (don’t know if this is what you meant), and got:
“curl: (7) Failed to connect to localhost port 8000 after 0 ms: Connection refused”.
I am not very conversant with AWS, and I am trying to learn. There is quite a lot I don’t know, so I might be misunderstanding certain concepts. Please bare with me.