Unable to change field order in address DocType

Hi all,

we have an issue in ERPNext 9.2.16 (same in 9.1.7): when trying to change the field position of postal code (or other fields in the address DocType, as soon as the form is saved, the old position reverts, no error occurs.

Steps to reproduce:

  • Open address list > Customize
  • Move postal code to city (where it would usually be in western Europe)
  • Save.
  • Observe message “Address updated” but at the same time the field to jump back

Expected behavior:

  • user can re-order fields using customize

Actual behvaior:

  • customized order is not saved

Any clues?

Hi, insert new row below Address Line 2 called Postal Code.

Proceed to original postal code and check Is Hidden field. You will achieve desired result.

Hi @kennethsequeira,

thanks for this workaround. It worked (mostly). The only issue I had was that it ignored “hiding”. So even on new records I have now two postal codes. But at that, I can remove the original and keep the custom.

Still, I am puzzled why ERPNext reacts here in this way and requires a workaround…

@lasalesi thanks for the update!

With the suggested workaround, I am getting only one postal code in the form, unless you mean on the Customization page. We can’t delete it from there since it is a mandatory field and hence the option to hide.

Since you mention, this format is widely used in Western Europe, you can try to set the Address Template for your country. That should help too.