Unable to change Item List Quantity type to Int

Currently all my transactions on the system have unitary quantity values however the quantity type in Item Lists can only be set as currency or float. 
Is there a way to change this to Int? When I try to apply the change in customize form I receive an error saying "you cannot change this type to Int".

Also - The item unitary measures being used for the quantity has the "Only allow whole numbers" but the quantity is still displayed with as many number of digits as the float precision as the quantity field is marked as float.

Does this mean you want to have precision per field that overrides global precision value?

I want to see Quantity as a whole number. The UOM assigned to the item has the “Only allow whole numbers” but on any item lists, quantities have 5 digits which is the setting I have for float precision.

Ok. Now that it is clear what’s to be done, we can fix this :). Will get back to you once it is ready. Should be done in next week.

Glad to hear! I will stay tuned!
Thank you!

Hi Anand - Any updates?

Hi Federico,
Haven’t got around to work on it. Have been working on other stuff. I have this in my todo though, so will get back to you soon.

Once this is merged, your issue should be solved: https://github.com/frappe/frappe/pull/824

Hi Anand - The same should be applied to minimum order quantity in Item Master?

You can change Float precision to any value for a field via Customize Form.

Hi Anand - I receive the same error which is “Cannot change from Float to Int”.
Same error experienced for Quantity in the Item lists for which we opened a github issue.

Hi Federico,
Changing from Float to Int is very risky. It changes the data type in the table schema to INT, which truncates the data. Hence we don't allow it. However, if the float value does not have any decimals, it displays it as INT in the print format. So that should serve as a good workaround.