Unable to "Get items from open MR" in PO

I have created a Material Request (MR) and was trying to make a Purchase Order (PO).

Tried to make PO from MR and also tried to create a PO with “Get items from open MR” but the items are not being fetched.

I have checked that all the items in the MR have a supplier and company.

Has anyone encountered a similar issue?

What is MR type? It should be Purchase if you want to create PO

Thanks for the reply.

The MR type is Purchase. I have created the MR from Production Plan.

Hi @Viral_Mestry
Seems like that button needs to be checked. For now, why don’t use the dropdown “Get Items From” > there is an option to select from Material Request, Product Bundle, Supplier Quotation

Thanks for the reply @jaichavan

The issue with your suggested approach is that when I get items from a MR, it pulls up all the items in the MR. There may be multiple items in the MR which might have multiple suppliers.

Basically I want to pull up items from MR for a specific Supplier. Which I’m unable to.

When I select a Supplier in a PO, a button “Get Items from Open Material Requests” is displayed below it. But it seems the button doesn’t work.