Unable to install with simple script - Centos 7 newest with firewalld disabled

[root@erpnext tmp]# sudo bash setup_frappe.sh --setup-production
Installing for centos 7 amd64
In case you encounter an error, you can post on https://discuss.frappe.io

Adding centos mariadb repo
Installing packages for centos. This might take time…
Installing wkhtmltopdf
Configuring CentOS services
Starting services
Adding frappe user
Erzeugen der Mailbox-Datei: Die Datei existiert bereits
Installing frappe-bench
Setting up first site
Traceback (most recent call last):
File “/bin/bench”, line 9, in
load_entry_point(‘bench==0.0.0’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/cli.py”, line 60, in cli
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/cli.py”, line 456, in setup_production
File “/home/frappe/bench-repo/bench/production_setup.py”, line 64, in setup_production
os.symlink(os.path.abspath(os.path.join(bench, ‘config’, ‘supervisor.conf’)), os.path.join(get_supervisor_confdir(), supervisor_conf_filename))
OSError: [Errno 17] File exists
[root@erpnext tmp]#

@mruepp seems you already have a superivsor_conf (?) are you running this again? Just clean your folder and try again.

Was indeed the second install, I removed the mariadb and nginx rpms and deleted the frappe user and homedir. But similar error occured when installing from scratch:
Solution however was (and I reccomend putting into the Installwiki) to disable SELINUX.

1 Like

Add it yourself!