Unable to login using IOS app

The app gets stuck after I enter my server address and not errors or anything for looong time…

Is there a bug or I have to do anything ??!
I was working fine on my previous server but on my new installation it’s like this…

@ramielian For how long have you waited? It can take up to several minutes sometimes. On which version of iOS is app running on?

@strixaluco last time was over 5 minutes, am using 0.0.3 iPad version
The first time i installed the app it took seconds but now not…

I reinstalled the app many times but nothing change…

@ramielian sorry, maybe I wrote unclear, I meant which iOS version are you using.

@strixaluco OH SORRY i thought the version of the APP, am running ios 9.3

@strixaluco ok, now i just tried it in another way and it signed in in a second, i just added the http:// prefix to the server name…
@rmehta i thought this was fixed already in the earlier versions isnt it?!

Good that you’ve figured out. As far as I remember, it should work without http:// prefix though.

@strixaluco i saw a report last month i think about this and they said they fixed it, the report was the app not accepting the http:// but now its not accepting without http:// and also it is case sensitive letters.

@strixaluco @ramielian best to give http or https, otherwise the app will try for https and then ask for http

1 Like

@ramielian Given the fact, that application version is still 0.0.3 from Sep 2015, I assume that the problem is not on the app side, otherwise new version would be submitted.
@rmehta Thanks for clarification. Will application try to use http in case I explicitly put https?

@strixaluco no, it will only try to guess if you don’t put http: or https:

1 Like

I’ve been having problems with this myself. Here is what I’ve tried:
We have 2 versions of ERPNext running at the moment, 1 Hosted on ERPNext Servers (Hosted), and 1 self Hosted on our servers (Server)

Both Hosted and Server have no problems logging in on windows machines

Both Hosted and Server have no problems loggiing in on android machines

iOS 9.3.1:
Hosted: Can sign on in browser or in app.
Server: Cannot sign in on Safari, Chrome, Firefox, Dolphin, Opera Browsers. When attempting to log in, it shows “Not Permitted”. Cannot log in using server address with or without http://

@cpurbaugh when i had this issue i deleted the app and the browser cash and with the help above i added http:// and it worked…

now to say the truth frappe have some issues about the HTTPS and its configuration with nginex so if your server is using https you might deal with some problem here and there but anything else will go smoothly…

@rmehta is there a developing team for the IOS app and are you using webapp or downloaded data?!
i would like to help if i can in what i can…

Hmm…As of this afternoon it started working. I’ve got no idea why, I’m just glad it’s working.

@ramielian the app is just a cordova container. The app is pretty much run as a web-app. There is nothing really in the container. We don’t wan’t to release it now as we fear the app store will be flooded with clones.

Is there a way to make the app work with landscape mode? I use a keyboard case with my iPad, so I have to use ERPnext in a browser