Unable to upload images or attachments

Hi Everyone,

I am getting my items, letterhead, etc set up in ERPNext, and I am having an issue with uploading images and/ or attachments. It doesn’t report any specific errors, but it just says “uploading” (“saving” for the letterhead) and I included a screenshot just to show what I am seeing. Everything else seems to be functioning normally (we can add and save Items and other data just fine). Any suggestions would be extremely helpful.


1 Like

What is the size of your attachments ?

1 Like

Hi @srinivasragav. The file sizes are all under 1Mb. I had tried to even upload an image under 100kb in size and I get the same result.

Hi ,

Try running

bench --site all clear-cache

1 Like

Still no change

Which version are you in ? :confused:

I just installed it yesterday morning from the easy method on Github.

ERPNext: v6.27.25

Frappe Framework: v6.27.23

Edit your sites/site1.local/site_config.json file ,

add "max_file_size": 1000000, then bench --site all clear-cache

Please try

1 Like

It says “no such file or directory”. Is there a way to add it, or update it?

Use this command

bench set-config developer_mode 1

you will get this site_config.json file in /home/ommi/frappe-bench/sites/site1.local folder

1 Like

the directory you gave shows up as “no such file or directory” when I put it in. I tried using the string: /home/frappe/frappe-bench/sites/site1.local just to give it a shot and it shows up as a directory, but the site_config.json file still gets a “no such file or directory” response.

Ok. Heres where I am at

I found the site_config.json at the below directory:


Now, when I try to access the file to make the edits suggested by @srinivasragav I am getting “Permission denied”. I tried “bench set-config developer_mode 1” to see if that allowed me to have permission, but it still says Permission denied. Is there a way to gain permission?


You seem to be on a production environment , right ?

@srinivasragav that is likely the case, since this was installed from the easy method on Github. I’m unsure how to confirm it for you, though.

Run git status in the apps/frappe folder and tell the output

It seems async issue…try to reinstall nodejs…or just disable async bench --site yoursite set-config disable_async True

1 Like

Sorry @srinivasragav, can you tell me what the complete string is for the apps/frappe folder? I’m new at this, so I apologize for not knowing this stuff very well.

Hi Friend , even I’m a novice , I just searched few links relevant to your issue and posting it here for you . Try what @jof2jc had advised [quote=“jof2jc, post:16, topic:13899, full:true”]
It seems async issue…try to reinstall nodejs…or just disable async bench --site yoursite set-config disable_async True

anyway , for your question , check this ,

cd /home/ommi/frappe-bench/apps/frappe
git status

Hi @jof2jc. I tried your recommendation and it is still didnt change what I’m seeing

@srinivasragav, I appreciate you doing that to help me. I ran the string you provided, and just says:

#On branch master
nothing to commit, working directory clean