Understanding Modules

Hi There. So I’ve tried the demo and absolutely love ERPNext. I’m trying to learn as much about it as possible and have started thinking about ways to contribute to the community myself :slight_smile:

But first, I have a simple question. I noticed on the hosted version there seems to be lots of modules (HR, POS etc.). I’ve installed locally on macOS with frappe-bench and it doesn’t have those features. Is this only available for the paid hosting? If not, how do I enable? What am I misunderstanding?

Thanks guys!!!

It should have same modules, the might just be hidden or the user don’t have permission to access them. if you are administrator just search for modules setup and u can select to show and hide modules.

Right. That’s what I thought. Yet my only available options are Core, File Manager, Website, Desk, Setup. When I go into show/hide I see Tools, Website, File Manager, Developer. Hmmm

“Modules are automatically hidden for users that have no permissions on the documents within that module. For example, if a User has no permissions on Purchase Order, Purchase Request, Supplier, the “Buying” module will automatically hidden for that User.”

So make sure that the user you wanna show the modules for have permission

Also it seems that you only downloaded frappe without Erpnext. You have to install erpnext in apps

Right understood. I’ve both Frappe and ERPNext installed in my apps directory. How can I check to see if I’ve installed an app within my sites directory?

The easy way is to click on the user then about and it will show you the installed apps

I’ve been trying to install locally for about 2 weeks, I finally was able to fix all the installation errors and get things up and running. I’m signed in as the default administrator. This is a little off. I’m hoping it’s just a UX problem otherwise it looks like I’d have to reinstall. Could something have gone wrong? I can’t seem to find these anywhere.

My Suggestion to you, if you wanna play around with erpnext and learn its inner workings, then your best option is to use a virtual machine. that way you can break everything the reopen a fresh machine in just a minute so you never worry about breaking anything.
And the awesome team here at Erpnext already prepared a virtual image thats ready to use. all you need is virtual box app install on your mac
here is the link

Thanks, yes I saw that. I’ve also signed up for a free account and had enough time to play with it, as I said, absolutely love it. My local installation works fine, I just don’t have access to all the apps. I’ll do some more digging and see what I can find. I must be missing something.

A couple suggestions…

  1. Make sure the roles are not disabled:
    Setup >> Roles

  2. Make sure the modules are visible:
    Setup >> Show / Hide Modules

Thanks! I gave that a shot. All roles are enabled and all 4 modules are enabled.Updated bench, restarted services, cleared cache. Still doesn’t seem to want to give me all the modules.

Can you give a screenshot of the Setup >> Roles screen and Setup >> Show / Hide Modules (For Everyone) screen?


Weird… It just doesn’t look like ERPNext is installed.
can you paste the full results of bench migrate (in the console)

➜ frappe-bench bench migrate Migrating portal.local Updating frappe : [========================================] ➜ frappe-bench

It looks like you don’t actually have erpnext installed.


bench get-app erpnext http://github.com/frappe/erpnext
bench --site portal.local install-app erpnext

Yeah, very strange. Here’s the result for both commands:

➜ frappe-bench bench get-app erpnext http://github.com/frappe/erpnext
INFO:bench.app:getting app erpnext
fatal: destination path 'erpnext' already exists and is not an empty directory.
Traceback (most recent call last):
File "/usr/local/bin/bench", line 9, in <module>
load_entry_point('bench', 'console_scripts', 'bench')(), in cli
File "/Library/Python/2.7/site-packages/click/core.py", line 716, in __call__
return self.main(*args, **kwargs)
File "/Library/Python/2.7/site-packages/click/core.py", line 696, in main
rv = self.invoke(ctx)
File "/Library/Python/2.7/site-packages/click/core.py", line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/Library/Python/2.7/site-packages/click/core.py", line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/Library/Python/2.7/site-packages/click/core.py", line 534, in invoke
return callback(*args, **kwargs)
File "/Users/jessemainee/dev/bench-repo/bench/commands/make.py", line 30, in get_app
get_app(git_url, branch=branch)
File "/Users/jessemainee/dev/bench-repo/bench/app.py", line 62, in get_app
cwd=os.path.join(bench_path, 'apps'))
File "/Users/jessemainee/dev/bench-repo/bench/utils.py", line 130, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git clone http://github.com/frappe/erpnext --depth 1 --origin upstream
➜ frappe-bench bench --site portal.local install-app erpnext
Installing erpnext...

ERPNext can only be installed on a fresh site where the setup wizard is not completed
You can reinstall this site (after saving your data) using: bench --site [sitename] reinstall

Have you tried bench --site portal.local reinstall ?


➜ frappe-bench bench --site portal.local reinstall This will wipe your database. Are you sure you want to reinstall? [y/N]: y Installing frappe... Updating frappe : [========================================] Updating country info : [========================================] Set Administrator password: Re-enter Administrator password: Installing fixtures... *** Scheduler is enabled *** ➜ frappe-bench