UOM error when creating new UOM

Two issues…

First, I have no idea what ERPnext is defining as Nos. Here in the USA Nos stands for “New Old Stock” and it is not really a unit of measure as much as a category of products. So what exactly does it represent here as a unit of measure?

Second, I mix chemicals and sell end product in pints, quarts, gallons, 5 gallon containers, and 55 gallon drums.

I started creating the new UOM. The Pints, Quarts, and Gallons all created just fine, but when I tried to create the 5gal as a UOM it didn’t show up in the list. However, when I tried to create it again I got an error indicating that the UOM already exist, but it doesn’t show up anywhere in the list!!!

Is there a bug in OUM if it starts with a numeric character?

Is there a way to get the system to show me the 5gal UOM it thinks it has created?

Is there a way to delete it if it is not displayed?

Is there a way to edit UOM after they are created? So far it only appears that you can completely delete one (if you can see it in the list) and recreate it with your edits.


I believe in ERPNext NOS is “Not Otherwise Specified”.

Ok, that seems to answer the NOS question. Thank you!

Now I just need to know what is up with the UOM I created not showing up in the list.


Hi. Welcome to the community.
AFAIK: Nos stands for numbers.

A simple reload should probably fix things for you.

Thanks, but it still did not resolve the issue. Here is a screen shot showing the UOM category thinking it has 8 items in the list but only 7 items show up. If you try to create a UOM called 5gal you get the message that it is a duplicate and already exists!

Ok, it seemed strange but I just started clicking on things out of frustration and when I clicked on the x next to the Show Filters button, the 5gal UOM was added to the list. I had clicked on the same x earlier to delete what I thought was a filter setting and that is when the ID=“” was displayed next to the filter button. That seemed like it was a null filter as compared to the default. Apparently the filters are in layers and I needed to delete several of them?!? Not sure why. So here is the new screenshot. Any idea why it acted this way?

Is there a way to default absolutely NO filters? That would be much preferred when creating the lists.