UOM showing up differently

Hi guys, I’m having some issues with the UOM for the delivery note at the moment.

Old ginger was sold at a different UOM(Box), and show up as “Box” on the delivery note, and when we switch to print view of the note out it shows as KG instead.

I tried customising the print template for the delivery note to add UOM but it’s also not showing up as well. Am I missing anything here?

Is Box Stock UOM or just UOM, try and check which one of them is checked yes to be visible.

How do I check? This is all I see.

If you don’t have a custom Print Format for Delivery Note in place then you ought to customize the Standard format to get your desired format. Follow these steps.

Click on Print Icon next to menu on your Delivery Note, and then the preview opens. Now we ought to customize it so then you click on Customize button as shown below:

Then you get this view (which is a Print Format Builder view)

Scroll down to Items table, and click on Select Columns button and then uncheck Stock UOM, and check UOM and click on Update button at the top right corner of this dialog box.

Save this print format. Then next time you print your delivery note select that print format you just made and you should be able to see box in your print.

I did that and this is my current table.

but its still showing KG on print.

Where the first 2 items should have been Box and Packet.

Have you selected the new Print Format you just selected or is it still the old one i.e. Standard ?

Change it from here - from standard to the new one you just created.

Also, did you save that format you customized or not ?

I’ve created a new print format and renamed it differently(dot).

I’ve also used “dot” as the default print format.

We’ve just updated to V 10.1.55 and got the same issue , any solution for showing correct UOM

Both might be caused by a cache problem. Have you tried clearing cache and doing a user reload?

You mean that we do " Reload " in system ? Already done many times but no change .

bench --site all clear-website-cache

Done , but no change.
My case. Adding more details , I installed database of Version 10.1.53 on ERPNEXT V 10.1.55 so I think there is a error when install like this but don’t know how to fix it.