Update Issue - Cannot access DESK after bench update

I just updated moments ago and now I cannot get into the desk. I can login, but then it returns me to a screen with JSON that resembles the menu options under where my name would be, but no icons appear and only a large ERPNEXT logo in the middle of screen. A small sample of this JSON is “”, “hide_footer_signup”: 1, “home_page”: “my site name*”, “home_page_is_products”: 0, “idx”: “0”, “linked_in_share”: "

Any thoughts? This last update appeared pretty involved… lots of moving/deleting of images and docs.

 1650 files changed, 23410 insertions(+), 18610 deletions(-)

If anyone is reading these, I restored the pre-update database, ran bench migrate and still no go. A better redacted version of what I am seeing.

Are you running on ERPNext cloud?
Which version you are running earlier and which version you are trying to upgrade or update to?

I am running local. I was running 995d8e7…983d205 and it upgraded to the latest master as of this morning at 2:00 AM. I just tried another bench update to see if the build had been updated since and it has not.

I found this in the web.error.log

2015-12-07 13:33:27,039 Request Error 
 site: dev.site.local
 form: {'cmd': u'frappe.desk.moduleview.get', 'module': u'Core'}

Traceback (innermost last):
  File "/home/frappe/frappe-bench/apps/frappe/frappe/app.py", line 67, in application
    response = frappe.handler.handle()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/handler.py", line 77, in handle
  File "/home/frappe/frappe-bench/apps/frappe/frappe/handler.py", line 94, in execute_cmd
    ret = frappe.call(method, **frappe.form_dict)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/__init__.py", line 788, in call
    return fn(*args, **newargs)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/moduleview.py", line 13, in get
    data = get_data(module)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/moduleview.py", line 37, in get_data
  File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/moduleview.py", line 183, in set_last_modified
    item["last_modified"] = get_last_modified(item["name"])
  File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/moduleview.py", line 201, in get_last_modified
    last_modified = frappe.cache().hget("last_modified", doctype, _get)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/utils/redis_wrapper.py", line 123, in hget
    value = generator()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/moduleview.py", line 188, in _get
    last_modified = frappe.get_all(doctype, fields=["max(modified)"], as_list=True, limit_page_length=1)[0][0]
  File "/home/frappe/frappe-bench/apps/frappe/frappe/__init__.py", line 936, in get_all
    return get_list(doctype, *args, **kwargs)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/__init__.py", line 909, in get_list
    return frappe.model.db_query.DatabaseQuery(doctype).execute(None, *args, **kwargs)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/model/db_query.py", line 50, in execute
    return self.build_and_run()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/model/db_query.py", line 62, in build_and_run
    return frappe.db.sql(query, as_dict=not self.as_list, debug=self.debug)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/database.py", line 146, in sql
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/cursors.py", line 205, in execute
    self.errorhandler(self, exc, value)
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
 OperationalError: (1412, 'Table definition has changed, please retry transaction')

Anyone have any thoughts on this? I just updated (bench update) again today hoping the fix would be rolled into the git by now and the same problem exists. I certainly can’t be the only one this has happened to, am I?

Seems weird. Try searching for that error on Google.