Update to 10.1 Not working - yarn keeps creating file yarn.lock?


I just tried to update to latest 10.1.2 version. When I do bench update, it shows:
Cannot proceed with update: You have local changes in app “frappe” that are not committed.

Here are your choices:

  1. Merge the frappe app manually with “git pull” / “git pull --rebase” and fix conflicts.
  2. Temporarily remove your changes with “git stash” or discard them completely
    with “bench update --reset” or for individual repositries “git reset --hard”
  3. If your changes are helpful for others, send in a pull request via GitHub and
    wait for them to be merged in the core.

After that I did bench update --reset

And after that I tried bench update again, but the same error shown.

I did tried to do “git diff” on apps/frappe but there is no difference.

Although I can successfully update to 10.1.2 using bench update --reset, but doing --reset every time feels not right.

Did I do anything wrong?

I found the issue. Looks like yarn keep creating file yarn.lock in apps/frappe folder. So everytime I need to do git add --all and git stash before bench update

Any permanent solution for this?

Should be resolved with New Build System: Rollup by netchampfaris · Pull Request #5010 · frappe/frappe · GitHub