Upgrading from V8 to V10: Problems being faced

I did an upgrade from V8 to V10 after taking backups. Now the first hurdle for me was a validation error: Options must be a valid docType for field payment terms template. This was solved by method provided by netchampfaris. Later the upgrade went smoothly without error. But when i login there is a blank screen with an E-logo.

So i switched to V8.x.x and found that login was working but now none of the records are getting saved. When we press the save button nothing saves and the status remains Not saved.

Please let me know how i can either go to V10 or remain at V8 but with things working.
Thanks in advance

Hi @arpanzen

Trust you’re doing great. Most likely your V10 is fine… just some cache issues. Try the following:

  1. Clear your bowser cache
  2. Open a fresh browser page and try logging in again

If you’re still having issues, try the following commands:

  1. bench clear-cache
  2. bench build

Open a fresh browser page and try logging in again


Thanks for pointing me in the right direction, got it working

When i did a bench build i got
Babelify errors : Unknown plugin “transform-object-rest-spread”

I had to install the dependency

sudo npm install babel-plugin-transform-object-rest-spread

After that, the following error occurred on bench build:

Error: Couldn’t find preset “env” relative to directory “/home/frappe/frappe-bench/sites”

This was resolved with

sudo npm install babel-preset-env

And now it works.
Thanks Again

1 Like