Upload item list with images

Trying to import items with image files path as /files/ and ftp actual files to that location. It shows files name but doesn’t work. Any help?

You also have to create File Data records

I ftp files to location, than created following file for “file data” import, it says import success but shows file size as 0. also tried deleting and reimporting items before and after this import. Let me know

DocType: File Data
Column Labels: ID File Name File URL Attached To DocType Attached To Name File Size Content Hash
Column Name: name file_name file_url attached_to_doctype attached_to_name file_size content_hash
Mandatory: Yes No No No No No No
Type: Data (text) Data Data Link Data Int Data
Info: Valid DocType Integer
Start entering data below this line
“File000022” lg-ALE-275073.jpg /files/lg-ALE-275073.jpg Item ALE-275073
“File000023” lg-ALE-334712.jpg /files/lg-ALE-334712.jpg Item ALE-334712
“File000024” lg-ALE-339590.jpg /files/lg-ALE-339590.jpg Item ALE-339590
“File000025” lg-ALE-343067.jpg /files/lg-ALE-343067.jpg Item ALE-343067
“File000026” lg-ALE-386956.jpg /files/lg-ALE-386956.jpg Item ALE-386956
“File000027” lg-ALE-393490-8.jpg /files/lg-ALE-393490-8.jpg Item ALE-393490-8
“File000028” lg-ALE-393495.jpg /files/lg-ALE-393495.jpg Item ALE-393495

Yeah it won’t automatically pull file sizes. But that should not be a problem.

It’s not showing file name in item but not the picture

should i try putting file sizes? is there any documentation on how to link images to items… as i m testing this and have more than 4000+ images to links to items

sorry, but what i mean here is … it is showing file name in item but not picture

Are you also setting the “Attached to DocType” and “Attached to Docname” properties?

@Rushabh, i check again and the sample data i was using to test didn’t had images uploaded so checked items for which i had images and it WORKS without even uploading ‘File Data’ records. Even it works for webpage. Only thing, some larger vertical images worked for items list but not for website!! is there any size limitation?

Size should not be an issue.

Can you be more specific how you fixed your problems? It reads very similar to my problem. I have followed all suggestions, the file is listed under attachments but not on the Item profile thumbnail. Clicking on the thumbnail offers a window which has the attachments available in the drop-down list. After selecting the attachment it works. Can not find anything different.

Hi @darshakusa, i have de the same issue of @jasondawsonco. Any idea?