Urllib3 1.24 is incompatible - unable to setup on a new VPS

Hey folks,

I followed Guide: Easy Install ERPNext on DigitalOcean Successfully tested to install ERPNext (–production) on an Ubuntu 16.04.4 VPS on DigitalOcean. However it is failing citing urllib version mismatch.

I also tried the Python 3 installation approach (https://www.digitalocean.com/community/questions/tutorial-request-erpnext-platform?answer=41581) without success.

The issue happens in the Ansible task “bench : python2 bench init for production” which runs bench init /home/frappe/frappe-bench --frappe-path https://github.com/frappe/frappe --frappe-branch master and crashes with the following error:

RequestsDependencyWarning: urllib3 (1.24) or chardet (3.0.4) doesn't match 
a supported version! RequestsDependencyWarning)

/home/frappe/frappe-bench/env/bin/python: No module named ordered_dict

This error is mentioned initially itself when running raw.githubusercontent.com/frappe/bench/master/playbooks/install.py:

requests 2.19.1 has requirement urllib3<1.24,>=1.21.1, 
but you'll have urllib3 1.24 which is incompatible.

And not sure if relevant, but this error happened multiple times as well:

warning: unable to access '/home/frappe/.config/git/attributes': Permission denied

Any ideas I can try out?


Hi @jasim

Could you try the suggestion in the thread below and see if it works?


Have deployed a fix. Can you try again and confirm.

Thanks for the quick response @codingCoffee.

I tried again and now playbooks/install.py seems to install urllib3-1.23 correctly, but frappe-bench is failing due to v1.24.

Here’s the entire install log

So I think the fix is merged on the hotfix branch, but not yet merged into the master branch. Will be doing a release shortly, you may check after that.

I did a clean install and everything worked nicely. Thanks a lot for the help, @codingCoffee and @wale